summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBradley Smith2008-01-21 00:16:45 +0000
committerBradley Smith2008-01-21 00:16:45 +0000
commite6e7222d5a730368ed4e84c2e0f55427460e5230 (patch)
treee608410401099ccebe7ffa21de9336d78c78efc9 /lib/Makefile.am
downloadgnurobots-e6e7222d5a730368ed4e84c2e0f55427460e5230.tar.gz
Imported GNU robots from CVS.
Signed-off-by: Bradley Smith <brad@brad-smith.co.uk>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..f3d6283
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,48 @@
+##
+## lib/Makefile.am
+##
+## GNU Robots is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2 of the License, or
+## (at your option) any later version.
+##
+## GNU Robots is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with GNU Robots; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##
+
+SUBDIRS = xpm
+
+if USE_CURSES
+CURSES_PLUGIN=libgrobots-curses.la
+else
+CURSES_PLUGIN=
+endif
+
+if USE_X11
+X11_PLUGIN=libgrobots-x11.la
+else
+X11_PLUGIN=
+endif
+
+INCLUDES = $(GLIB2_CFLAGS) $(CURSES_CFLAGS) $(X_FLAGS) -I$(top_builddir)/include
+
+pkglib_LTLIBRARIES = libgrobots-text.la $(CURSES_PLUGIN) $(X11_PLUGIN)
+
+libgrobots_text_la_SOURCES = textplugin.c
+libgrobots_text_la_LDFLAGS = -module -avoid-version
+libgrobots_text_la_LIBADD = $(GLIB2_LIBS)
+
+libgrobots_curses_la_SOURCES = cursesplugin.c
+libgrobots_curses_la_LDFLAGS = -module -avoid-version
+libgrobots_curses_la_LIBADD = $(GLIB2_LIBS) $(CURSES_LIBS)
+
+libgrobots_x11_la_SOURCES = x11plugin.c
+libgrobots_x11_la_LDFLAGS = -module -avoid-version
+libgrobots_x11_la_LIBADD = $(GLIB2_LIBS) $(X_LIBS)
+