summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBradley Smith2008-05-05 22:36:42 +0100
committerBradley Smith2008-05-05 22:36:42 +0100
commit5fce44d580c24ac4c817ca62614670b04b4cf10b (patch)
treec6a8fc270fbf0db982d84b6653cf6520500da14c /lib/Makefile.am
parentMake UI update in a loop, and thread out input. (diff)
downloadgnurobots-5fce44d580c24ac4c817ca62614670b04b4cf10b.tar.gz
Scrap plug-able interfaces in preparation for GTK GUI.
Signed-off-by: Bradley Smith <brad@brad-smith.co.uk>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am52
1 files changed, 0 insertions, 52 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
deleted file mode 100644
index 0712921..0000000
--- a/lib/Makefile.am
+++ /dev/null
@@ -1,52 +0,0 @@
-## Copyright (C) 2008 Bradley Smith <brad@brad-smith.co.uk>
-##
-## lib/Makefile.am
-##
-## GNU Robots is free software; you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2 of the License, or
-## (at your option) any later version.
-##
-## GNU Robots is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU General Public License for more details.
-##
-## You should have received a copy of the GNU General Public License
-## along with GNU Robots; if not, write to the Free Software
-## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
-SUBDIRS = xpm
-
-if USE_CURSES
-CURSES_PLUGIN=libgrobots-curses.la
-else
-CURSES_PLUGIN=
-endif
-
-if USE_X11
-X11_PLUGIN=libgrobots-x11.la
-else
-X11_PLUGIN=
-endif
-
-INCLUDES = $(GLIB2_CFLAGS) $(CURSES_CFLAGS) $(X_FLAGS) -I$(top_builddir)/include $(READLINE_CFLAGS)
-
-pkglib_LTLIBRARIES = libgrobots-text.la $(CURSES_PLUGIN) $(X11_PLUGIN)
-
-libgrobots_text_la_SOURCES = textplugin.c
-libgrobots_text_la_LDFLAGS = -module -avoid-version
-libgrobots_text_la_LIBADD = $(GLIB2_LIBS) $(READLINE_LIBS)
-
-libgrobots_curses_la_SOURCES = cursesplugin.c
-libgrobots_curses_la_LDFLAGS = -module -avoid-version
-libgrobots_curses_la_LIBADD = $(GLIB2_LIBS) $(CURSES_LIBS)
-
-libgrobots_x11_la_SOURCES = x11plugin.c
-libgrobots_x11_la_LDFLAGS = -module -avoid-version
-libgrobots_x11_la_LIBADD = $(GLIB2_LIBS) $(X_LIBS) $(READLINE_LIBS)
-
-EXTRA_DIST =\
- cursesplugin.h \
- textplugin.h \
- x11plugin.h