summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Judson Rosen2017-03-31 05:28:00 -0400
committerJoshua Judson Rosen2017-04-01 16:01:10 -0400
commit582d3bf96bc0ff3e3b242536d2433a8ed8d01e40 (patch)
treeeb4fbff18395ca0e9e90250c00a4e62847912dbc /configure.ac
parentconfigure: check for GLib from beyond the g_type_init era (diff)
downloadgnurobots-582d3bf96bc0ff3e3b242536d2433a8ed8d01e40.tar.gz
Drop undocumented readline dependency
Yet another of the niceties that comes out of just using guile's REPL is that readline support is just figured out when building guile; so by the time gnurobots is being built, readline support is either there or it isn't--and even if our guile isn't readline-enabled, we can still just run without readline (though, in practice, I don't think I've ever seen a build of guile in the last 15 years that didn't have readline...).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 26ffaa1..d102a3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,30 +39,6 @@ AC_SUBST(schemedir)
mapsdir="\$(pkgdatadir)/maps"
AC_SUBST(mapsdir)
-for termlib in ncurses curses termcap terminfo termlib ; do
- AC_CHECK_LIB(${termlib}, tgoto,
- [READLINE_EXTRA="-l${termlib}"; break])
-done
-
-AC_CHECK_LIB(readline,readline,[READLINE_LIBS=-lreadline],
- AC_MSG_ERROR([
-
-You need the GNU Readline library to build this program.
-
-]),[$READLINE_EXTRA])
-
-AC_CHECK_HEADER(readline/readline.h,
- [READLINE_CFLAGS=-I/usr/include/readline/], AC_MSG_ERROR([
-
-You need the GNU Readline headers to build this program.
-
-]))
-
-READLINE_LIBS="$READLINE_LIBS $READLINE_EXTRA"
-
-AC_SUBST(READLINE_LIBS)
-AC_SUBST(READLINE_CFLAGS)
-
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(unistd.h)