summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJakub Sławiński2005-08-05 21:45:31 +0200
committerJoshua Judson Rosen2014-07-17 21:14:59 +0200
commit43e8714797d40bcf63efab428dcd25f9caf1d52b (patch)
tree796974a873a97f2a44f872f3dd3587508e35aa64 /src/Makefile.am
parentv0.7.1 (diff)
downloadapf-43e8714797d40bcf63efab428dcd25f9caf1d52b.tar.gz
v0.7.2
- Added: http proxy basic authorization - Fixed: logging initialization after some value checking - Fixed: auto-reconnect failure when --nossl option is set - Added: auto-reconnect when afserver is not reachable on start - Added: auto-reconnect after normal afserver quit - Added: per user statistics: idle time, amount of downloaded/uploaded bytes and current download/upload rate - Added: support for https proxies - Added: possibility to bind sockets on different interfaces - Fixed: receiving incomplete headers from afclient - Fixed: close user connections by afclient
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am26
1 files changed, 16 insertions, 10 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9910314..f512ce8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,12 +1,18 @@
bin_PROGRAMS = afserver afclient
-afserver_SOURCES = afserver.c network.c file.c stats.c buflist.c remoteadmin.c \
- server_check.c server_set.c server_eval.c server_find.c server_remove.c \
- make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c \
- http_proxy_functions.c http_proxy_server.c server_get.c thread_management.c \
- server_signals.c usage.c logging.c audit.c daemon.c
+afserver_SOURCES = afserver.c network.c file.c stats.c buf_list_node_struct.c buf_list_struct.c \
+ server_remoteadmin.c server_check.c server_set.c server_eval.c server_find.c \
+ server_remove.c make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c \
+ clientnames.c usernames.c http_proxy_functions.c http_proxy_server.c server_get.c \
+ thread_management.c server_signals.c usage.c logging.c daemon.c ssl_fd_struct.c \
+ user_stats_struct.c usr_cli_struct.c connect_user_struct.c string_functions.c \
+ audit_list_node_struct.c audit_list_struct.c connect_client_struct.c timeval_functions.c \
+ header_buffer_struct.c
afclient_LDFLAGS = ${USE_RDYNAMIC} ${LINKED_LDLIB}
-afclient_SOURCES = afclient.c network.c stats.c buflist.c modules.c remoteadmin.c \
- make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c \
- http_proxy_functions.c http_proxy_client.c thread_management.c \
- client_reverse_udp.c server_check.c client_initialization.c client_shutdown.c \
- client_signals.c usage.c logging.c audit.c daemon.c base64.c ssl_routines.c
+afclient_SOURCES = afclient.c network.c stats.c buf_list_node_struct.c buf_list_struct.c modules.c \
+ client_remoteadmin.c make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c \
+ usernames.c http_proxy_functions.c http_proxy_client.c \
+ http_proxy_options_struct.c thread_management.c client_reverse_udp.c server_check.c \
+ client_initialization.c client_shutdown.c client_signals.c usage.c logging.c \
+ daemon.c base64.c ssl_routines.c connect_user_struct.c user_stats_struct.c \
+ string_functions.c ar_options_struct.c audit_list_node_struct.c audit_list_struct.c \
+ ssl_fd_struct.c timeval_functions.c