summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Sławiński2006-02-05 15:14:03 +0100
committerJoshua Judson Rosen2014-07-17 21:15:02 +0200
commitb457fec36399c1f7de093d5e92bb4fa453b79c86 (patch)
tree2084c9a78d40213015e6f10e3e9e01bc4c0c51f1 /configure.ac
parentUpdate copyright statements. (diff)
downloadapf-b457fec36399c1f7de093d5e92bb4fa453b79c86.tar.gz
v0.8
- Fixed: infinite loop after buffering message - Fixed: corrupt packets after closing connections in the stopped state - Fixed: bug in mapping user numbers between afclient and afserver - Fixed: premature close of the service connection - Fixed: invalid buffering when the connection is closing - Added: Multiple tunnels in one afclient<->afserver connection
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 88f591c..761e9fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,8 +2,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([Active port forwarder], [0.7.5], [jeremian@poczta.fm], [apf])
-AM_INIT_AUTOMAKE([apf], [0.7.5])
+AC_INIT([Active port forwarder], [0.8], [jeremian@poczta.fm], [apf])
+AM_INIT_AUTOMAKE([apf], [0.8])
AC_COPYRIGHT([
Copyright (C) 2003-2006 jeremian - <jeremian [[at]] poczta.fm>
===================
@@ -30,6 +30,18 @@ AC_CONFIG_FILES([Makefile
CFLAGS="-pedantic -Wall -O2"
+# Enabling/disabling asserts and debugging
+AC_MSG_CHECKING(whether to enable debugging)
+AC_ARG_ENABLE(debug, [ --enable-debug=[no/yes] turn on debugging
+ [default=no]],, enable_debug=no)
+if test "x$enable_debug" = "xyes"; then
+ CFLAGS="$CFLAGS -g"
+ AC_MSG_RESULT(yes)
+else
+ CFLAGS="$CFLAGS -DNDEBUG"
+ AC_MSG_RESULT(no)
+fi
+
# Checks for programs.
AC_PROG_CC
AC_PROG_GCC_TRADITIONAL