summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoshua Judson Rosen2015-02-17 00:37:08 -0500
committerJoshua Judson Rosen2015-02-17 00:37:08 -0500
commit714aebccbd7a4ab6ec0964d4580efd49171ba140 (patch)
treee71ac66a95848b1c0e8f47ea7d3df0e54c052d48 /configure.ac
parentNix mysleep(). (diff)
downloadapf-714aebccbd7a4ab6ec0964d4580efd49171ba140.tar.gz
Remove HTTP proxy support.
There are plenty of popular, readily-available external tools that, frankly, provide better options for going through proxies-- both of the HTTP variety and others (corkscrew, httptunnel, socat...); and dropping our internal implementation results in a significant reduction in code complexity--including the complete elimination of multithreading and all of the worries that go along with it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4d029fa..db59cae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,7 +66,6 @@ AC_CHECK_LIB([dl], [dlopen],
USE_RDYNAMIC=""
])
AC_SUBST(USE_RDYNAMIC)
-AC_CHECK_LIB([pthread], [pthread_create], [], [])
AC_CHECK_LIB([socket], [socket], [], [])
AC_CHECK_LIB([nsl], [gethostbyaddr], [], [])
AC_CHECK_LIB([crypto], [X509_sign], [], [])