summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a6ccd11..282b514 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,13 @@
bin_PROGRAMS = afserver afclient
+afserver_LDFLAGS = ${LINKED_PTHREADLIB}
afserver_SOURCES = afserver.c network.c file.c stats.c buflist.c remoteadmin.c \
server_check.c server_set.c server_eval.c server_find.c server_remove.c \
- make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c
-afclient_LDFLAGS = ${USE_RDYNAMIC} ${LINKED_LDLIB}
+ make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c \
+ http_proxy_functions.c http_proxy_server.c server_get.c thread_management.c \
+ server_signals.c usage.c logging.c audit.c
+afclient_LDFLAGS = ${USE_RDYNAMIC} ${LINKED_LDLIB} ${LINKED_PTHREADLIB}
afclient_SOURCES = afclient.c network.c stats.c buflist.c modules.c remoteadmin.c \
- make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c
+ make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c \
+ http_proxy_functions.c http_proxy_client.c thread_management.c \
+ client_reverse_udp.c server_check.c client_initialization.c client_shutdown.c \
+ client_signals.c usage.c logging.c audit.c