summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJakub Sławiński2005-06-07 12:06:18 +0200
committerJoshua Judson Rosen2014-07-17 21:14:58 +0200
commit32aff2b27ccc3b3e51fb6f0bd77fe0073827c527 (patch)
treef2fc2530a6960f6fdf4d63eb80c4f61342250bbd /src/Makefile.am
parentv0.6 (diff)
downloadapf-32aff2b27ccc3b3e51fb6f0bd77fe0073827c527.tar.gz
v0.7
- Added: http proxy tunnels between afserver and afclient - Fixed: sigint interception with threads enabled (in http proxy mode) - Fixed: FATAL ERROR in afclient in some situations after close of afserver when http proxy mode is enabled - Added: afclients can connect directly to afserver with enabled proxy mode - Fixed: timeout routine in http proxy tunnels - Added: 'rshow' command in ra mode displays 'tunneltype' - Fixed: printing IP of clients when http proxy mode is enabled - Added: 'tunneltype' per client in ra mode after 'cshow' command - Fixed: closing connection when http proxy mode is enabled - Fixed: threads initialization - Fixed: afserver closing after sigint - Fixed: afclient threads initialization - Added: 'version' option to display program version number - Modified: establishing afclient<->afserver connection - Added: 'keep-alive' option - Fixed: using 'proxyport' without 'proxyname' - Added: auto-reconnect feature to afclient - Added: 'ar-tries' and 'ar-delay' options - Modified: http proxy logging - Fixed: closing connection with afclient after receiving id - Fixed: thread closing due to wrong initialization sequence - Fixed: small bug in initialization process - Heavily Modified: logging routines - Added: audit option - Modified: default dateformat is now ISO 8601 - Modified: printing usage - Fixed: bug in threads' initialization in afclient - Added: 'timeout' and 'dateformat' options in ra mode - Modified: empty dateformat disables printing '[] ' - Added: 'audit' and 'dnslookups' options in ra mode - Fixed: afserver freeze bug - Added: 'kuser' and 'kclient' options in ra mode - Fixed: bug in starting afclient in ra mode - Added: audit log printed also after kicking the client
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a6ccd11..282b514 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,13 @@
bin_PROGRAMS = afserver afclient
+afserver_LDFLAGS = ${LINKED_PTHREADLIB}
afserver_SOURCES = afserver.c network.c file.c stats.c buflist.c remoteadmin.c \
server_check.c server_set.c server_eval.c server_find.c server_remove.c \
- make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c
-afclient_LDFLAGS = ${USE_RDYNAMIC} ${LINKED_LDLIB}
+ make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c \
+ http_proxy_functions.c http_proxy_server.c server_get.c thread_management.c \
+ server_signals.c usage.c logging.c audit.c
+afclient_LDFLAGS = ${USE_RDYNAMIC} ${LINKED_LDLIB} ${LINKED_PTHREADLIB}
afclient_SOURCES = afclient.c network.c stats.c buflist.c modules.c remoteadmin.c \
- make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c
+ make_ssl_handshake.c first_run.c inet_ntop.c realmnames.c clientnames.c usernames.c \
+ http_proxy_functions.c http_proxy_client.c thread_management.c \
+ client_reverse_udp.c server_check.c client_initialization.c client_shutdown.c \
+ client_signals.c usage.c logging.c audit.c