summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Sławiński2005-06-07 12:06:18 +0200
committerJoshua Judson Rosen2014-07-17 21:14:58 +0200
commit32aff2b27ccc3b3e51fb6f0bd77fe0073827c527 (patch)
treef2fc2530a6960f6fdf4d63eb80c4f61342250bbd /configure.ac
parentv0.6 (diff)
downloadapf-32aff2b27ccc3b3e51fb6f0bd77fe0073827c527.tar.gz
v0.7
- Added: http proxy tunnels between afserver and afclient - Fixed: sigint interception with threads enabled (in http proxy mode) - Fixed: FATAL ERROR in afclient in some situations after close of afserver when http proxy mode is enabled - Added: afclients can connect directly to afserver with enabled proxy mode - Fixed: timeout routine in http proxy tunnels - Added: 'rshow' command in ra mode displays 'tunneltype' - Fixed: printing IP of clients when http proxy mode is enabled - Added: 'tunneltype' per client in ra mode after 'cshow' command - Fixed: closing connection when http proxy mode is enabled - Fixed: threads initialization - Fixed: afserver closing after sigint - Fixed: afclient threads initialization - Added: 'version' option to display program version number - Modified: establishing afclient<->afserver connection - Added: 'keep-alive' option - Fixed: using 'proxyport' without 'proxyname' - Added: auto-reconnect feature to afclient - Added: 'ar-tries' and 'ar-delay' options - Modified: http proxy logging - Fixed: closing connection with afclient after receiving id - Fixed: thread closing due to wrong initialization sequence - Fixed: small bug in initialization process - Heavily Modified: logging routines - Added: audit option - Modified: default dateformat is now ISO 8601 - Modified: printing usage - Fixed: bug in threads' initialization in afclient - Added: 'timeout' and 'dateformat' options in ra mode - Modified: empty dateformat disables printing '[] ' - Added: 'audit' and 'dnslookups' options in ra mode - Fixed: afserver freeze bug - Added: 'kuser' and 'kclient' options in ra mode - Fixed: bug in starting afclient in ra mode - Added: audit log printed also after kicking the client
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6c5c7b8..6f56eff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,8 +2,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([Active port forwarder], [0.6], [jeremian@poczta.fm], [apf])
-AM_INIT_AUTOMAKE([apf], [0.6])
+AC_INIT([Active port forwarder], [0.7], [jeremian@poczta.fm], [apf])
+AM_INIT_AUTOMAKE([apf], [0.7])
AC_COPYRIGHT([
Copyright (C) 2003,2004,2005 jeremian - <jeremian [[at]] poczta.fm>
===================
@@ -56,6 +56,15 @@ AC_CHECK_LIB([dl], [dlopen],
])
AC_SUBST(LINKED_LDLIB)
AC_SUBST(USE_RDYNAMIC)
+AC_CHECK_LIB([pthread], [pthread_create],
+ [
+ LINKED_PTHREADLIB="-lpthread"
+ AC_DEFINE(HAVE_LIBPTHREAD, 1, [Define to 1 if you have the `pthread' library (-lpthread).])
+ ],
+ [
+ LINKED_PTHREADLIB=""
+ ])
+AC_SUBST(LINKED_PTHREADLIB)
# Checks for header files.
AC_HEADER_STDC